[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fatal IO error problem solved!

Larry Kollar <kollar@stc.net> reports the following:

SIAG 3.1.12 compiled up fine under MkLinux, with warnings. But when I
tried to run any of the applications, it would immediately die with:

XIO:  fatal IO error 0 (Unknown error) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.

This is great news. ;-) Not because it doesn't work, but because the
problem manifests itself on a platform I have access to so I can reproduce

The normal configuration and installation procedure, i.e.

./configure;make;make install

produces a binary linked with pthreads. It exhibits the problem as
described. This however:

rm config.cache
./configure --without-python
make install

produces a binary which is *not* linked with pthreads (or Python, of
course). And it works.

So the workaround for anyone experiencing this problem is to configure
without Python. 3.1.13 will have Python disabled by default; to turn it
on, use configure --with-python.

I hope this solution works for Suse Linux as well.