[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SIAG on an Alpha machine

I manage some Alpha 4000's and can take a look when I have some time. I
haven't used Siag on them since they are production boxes and usually only run
Oracle. My impression is that it is the int->pointer conversions that are
causing a problem, but that is not a big deal to fix. 

On Mon, 05 Oct 1998, Ulric Eriksson wrote: >On Sun, 4 Oct 1998, Brian
E.W. Wood wrote: >
>> I've been running Linux on various DEC Alpha platforms for a couple of years.
>> The major problem with this platform has been the lack of a decent graphical
>> browser and the lack of a decent WYSIWYG word processor. The browser problem
>> has been solved but the WP problem remains.
>> I spotted SIAG 3.0.5 a while back, hoping that it (actually pw) might be a
>> solution to the lack of a WP. It compiled without errors using egcs-1.1b.
>> Unfortunately when siag or pw is run it segfaults. Strangely, if I move the
>> mouse *very* slowly I can run for some time and actually create and print files
>> but it will eventually segfault. If I move the mouse quickly it will segfault i
>> mmediately. I tried the just-released 3.0.6 with the same result. This happens
>> with both siag and pw.
>> I did get a lot of compiler warnings about conversions between integers and
>> pointers. The Alpha uses 32-bit integers and 64-bit pointers so conversions
>> between them which work on an Intel machine (where they are both 32-bit) cause
>> strange things to happen on the Alpha.
>> Has anybody else tried tried running on an alpha? Is there anything I can do to
>> figure out where the problem lies? I have tried many other WPs like Maxwell,
>> Thot, Papyrus, AbiWord and others. SIAG comes the closest by far to being a
>> usable WP.
>I don't have an account on an alpha, so I can't test it. But here are a
>couple of clues.
>1. The conversion between XtPointer and int is something many X programs
>do and IIRC the definition of XtPointer is supposed to allow the
>2. There are many places where arguments which should be declared as long
>are instead declared as int. This makes no difference on a 32-bit
>platform, but I don't know if the Alpha has 64-bit longs.
>Have you tried running it under gdb? If it is an int/long problem, it
>should be easy to catch.