[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Siag 3.0.6 installation woes

---mosfet <mosfet@jorsm.com> wrote:
> Are you linking to libgdbm or libdb? I have also had some trouble
with gdbm,
> but have not had the time to look at it. If you do have libdb try that
> instead. 

I tried linking to libdb. (I gather that this is done by editing
topdir.mk so that DBLIB = -ldb.) This actually sort of worked. 'sh
INSTALL' sent no complaints to stderr, and siag, egon, and pw will
come up when I invoke them as root; however, when I invoke them as
myself, they segfault. I checked the permissions on the files--I
should be able to execute them.

This is the error message that strikes me as interesting:

> >ld: cannot open -lsiod: No such file or directory

I only get it when DBLIB = -lgdbm. What I don't get is what database
library files have to do with a library for an interpreter.

Hope this feedback helps.

--J. J.
Get your free @yahoo.com address at http://mail.yahoo.com