[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Siag 3.0.6 installation woes

On Fri, 2 Oct 1998, James Ramsey wrote:

> ---mosfet <mosfet@jorsm.com> wrote:
> >
> > Are you linking to libgdbm or libdb? I have also had some trouble
> with gdbm,
> > but have not had the time to look at it. If you do have libdb try that
> > instead. 
> I tried linking to libdb. (I gather that this is done by editing
> topdir.mk so that DBLIB = -ldb.) This actually sort of worked. 'sh
> INSTALL' sent no complaints to stderr, and siag, egon, and pw will
> come up when I invoke them as root; however, when I invoke them as
> myself, they segfault. I checked the permissions on the files--I
> should be able to execute them.
> This is the error message that strikes me as interesting:
> > >ld: cannot open -lsiod: No such file or directory
> I only get it when DBLIB = -lgdbm. What I don't get is what database
> library files have to do with a library for an interpreter.

Nothing! Siag doesn't use the database library at all. SIOD has those
bindings and Siag can use them if a sufficiently compatible library is
available to link with. But unless you intend to actually use Siag to
access a database, it's just bloat.

Comment out everything in the DB section (type XCOMM at the beginning of 
each line) of topdir.mk and recompile.